Report - Current Bugs and Issues

A forum for chatting about in-development game features.

Moderator: luciderous

nathanebht
Posts: 118
Joined: Sat Oct 21, 2017 2:48 pm

Re: Report - Current Bugs and Issues

Postby nathanebht » Sat Feb 16, 2019 5:46 am

Received a Humans declared war notification but I have not found them on the map. They are not available in my diplomacy screen either. Also the notification doesn't say who they declared war on.

Is this a bug or expected behavior?

Update:
Seems that the Humans were allied with another race I was at war with. Notification was them declaring war on me. So far this latest version, seems to be changed in what happens when your allied.

nathanebht
Posts: 118
Joined: Sat Oct 21, 2017 2:48 pm

Re: Report - Current Bugs and Issues

Postby nathanebht » Mon Feb 18, 2019 1:24 pm

Large numbers of enemy ships are going to a far corner of the map (allied empire) for no sensible reason. Allies like to send ships over very large distances to each other's empires. This behavior frequently leaves their important worlds undefended. Then they send their ships back when something happens.

Reported this before as an issue a month or two ago. Its still happening in a new game I started.

Update: Seems this doesn't happen if you go with the default number of stars on the largest map. I had been playing with 120 stars when the above was happening.
Last edited by nathanebht on Sat Feb 23, 2019 7:17 am, edited 1 time in total.

nathanebht
Posts: 118
Joined: Sat Oct 21, 2017 2:48 pm

Re: Report - Current Bugs and Issues

Postby nathanebht » Thu Feb 21, 2019 9:35 pm

The AI has a faulty memory of claiming a solar system. Ran into two examples in my current game.

I went to colonize the Arcusi system. AI #1 claimed they wanted it. I ok'd that they could have it for the better relations. AI #1 sent a colonizer. It arrived and then turned around for some unknown reason. Several turns later I then colonized it because they never did. No objection from AI #1 this time.

At the Eltanin system, I arrived with a colonizer. AI #2 also had a colonizer en-route and objected. I ok'd that for the better relations. Directed my colonizer to another system. An exploration ship of mine arrived at the system and their colonizer also arrived. I hailed their fleet and objected. AI #2 said, oh I didn't know it was a system you wanted. You can have Eltanin. No loss in relations.

Then many turns later, went to colonize Eltanin system. AI #2 became very displeased because I broke my promise to not colonize Eltanin.

nathanebht
Posts: 118
Joined: Sat Oct 21, 2017 2:48 pm

Re: Report - Current Bugs and Issues

Postby nathanebht » Sat Feb 23, 2019 7:25 am

An AI declared war on me and then peace in the same turn. In case its helpful, uploaded game_7895.

nweismuller
Posts: 330
Joined: Wed Apr 29, 2015 2:33 am

Re: Report - Current Bugs and Issues

Postby nweismuller » Wed Mar 06, 2019 8:57 am

game_7937: This is an annoying one. Combat at Asur III ended in a draw for no apparent reason after a single turn, before I even got all my ships in position to fire on the planetary defenses. Should be replicable by reversing one action and attacking Asur III.

matt3916
Posts: 7
Joined: Mon Jan 28, 2019 10:19 am

Re: Report - Current Bugs and Issues

Postby matt3916 » Mon Mar 18, 2019 6:02 am

Incorrect starvation? game_7965 sent. One of the reports is "Starvation at Mirsm II..." and yes, the population on Misam II did drop from the last turn. However, I have plenty of food empire wide and plenty of transports to carry it. Also don't have any hostile presence in the Misam system. Don't know why my people are starving.

Misam II was the site of a massive battle the previous turn. The remains of the hostile fleet departed and I then conquered Misam I (1 not 2). And, as you can see, I have potential starvation situations in three systems where I have to resolve battles. I'm thinking maybe the combination of every thing led to some glitch in the game mechanics. Especially since the game has already deducted population from Misam II.

zolobolo
Posts: 1233
Joined: Fri Nov 25, 2016 3:49 pm

Re: Report - Current Bugs and Issues

Postby zolobolo » Sat Mar 23, 2019 2:47 pm

Civilians and structures row overlapping on bombardment GUI

Also note:
- The humans on this planet have been harmonized but the normal civilian pop art is used to represent them
- After capturing the planet, the humans, all shown as having been ramonised before, are rebelling

Ideally I think that harmonisation should also increase their combat value
Attachments
Bombardment GUI.PNG
Bombardment GUI.PNG (385.71 KiB) Viewed 4031 times

Dragar
Posts: 86
Joined: Wed Mar 21, 2018 12:20 pm

Re: Report - Current Bugs and Issues

Postby Dragar » Sat Mar 30, 2019 7:14 pm

When humans salvage a battlecruiser, they get the (worthless) 'Battlecruiser' tech. Wouldn't it make more sense to get the tech equivalent, Dreadnoughts (unlocking Battleship)?

AMX
Posts: 43
Joined: Fri Nov 24, 2017 10:41 pm

Re: Report - Current Bugs and Issues

Postby AMX » Sat Mar 30, 2019 9:29 pm

Dragar wrote:When humans salvage a battlecruiser, they get the (worthless) 'Battlecruiser' tech. Wouldn't it make more sense to get the tech equivalent, Dreadnoughts (unlocking Battleship)?

Some races have both Battlecruisers and Dreadnoughts (Gremak and Orthin).

But you're right that capturing a tech that does nothing makes little sense, and should be addressed in some way.

Dragar
Posts: 86
Joined: Wed Mar 21, 2018 12:20 pm

Re: Report - Current Bugs and Issues

Postby Dragar » Mon Apr 01, 2019 7:41 pm

Force Lances say the penetrate, fully, Battle Shields and Force Fields. But in combat they clearly deplete the shield strength of both.

What is going on here? Is it just subsystem damage reducing the shield values somehow?

User avatar
PrivateHudson
Posts: 37
Joined: Tue Feb 12, 2019 7:59 am
Location: Chelyabinsk, Russia

Re: Report - Current Bugs and Issues

Postby PrivateHudson » Thu Apr 11, 2019 8:52 am

Sorry if already reported. Current Steam in_development version.
1. During tactical combat packs of enemy missiles often become invisible. They travel and hit normally, my PD fires at them, but no sprite is drawn. I even can fire normal weapons at them, if mouse over their position on tactical map by luck. I play with simplified graphics, because on default settings caught pair of crashes.
2. After plopping outpost, game for some reason is unable to scroll strategic map down by mousedrag for some time, possibly till turn end. I can mousedrag the map up, left, right, even down if I start dragging in any other direction other than down and hold the LMB, but not down outright.
3. After loading save (I always do Continue), colony screen shows only item being immediately produced, no queued ones. This again is only a display glitch, as adding another item to the queue reveals hidden items from the save, and they can be unqueued normally.

User avatar
PrivateHudson
Posts: 37
Joined: Tue Feb 12, 2019 7:59 am
Location: Chelyabinsk, Russia

Re: Report - Current Bugs and Issues

Postby PrivateHudson » Fri Apr 19, 2019 7:57 pm

Uploaded save 8067. Tinkers sent 2 requests to surrender the same star system in a single turn. While I can fulfill first, in the second Accept option is greyed, so war anyway.

User avatar
PrivateHudson
Posts: 37
Joined: Tue Feb 12, 2019 7:59 am
Location: Chelyabinsk, Russia

Re: Report - Current Bugs and Issues

Postby PrivateHudson » Thu Apr 25, 2019 8:24 pm

Something really must be done about simultaneous diplomatic requests compatibility. In my current game in the single turn: 1) tinkers have declared war - no demands, just plain DoW; 2) diplomatic incident between tinkers and phidi has happened; 3) I declined tinkers' request to sever relations with phidi - I have nothing to loose already; 4) I accepted phidi's request to sever relations with tinkers - I have nothing to sever already. Guess what this diplomatic maneuvering gave me? War with tinkers has been canceled, their fleets already enroute to my systems turned home!

User avatar
PrivateHudson
Posts: 37
Joined: Tue Feb 12, 2019 7:59 am
Location: Chelyabinsk, Russia

Re: Report - Current Bugs and Issues

Postby PrivateHudson » Fri May 03, 2019 6:42 pm

I've got an impression that anti-missiles during defensive fire don't consume ammo. Is this intended?

User avatar
Arioch
Posts: 1214
Joined: Sun Feb 01, 2015 12:56 am
Location: San Jose, California
Contact:

Re: Report - Current Bugs and Issues

Postby Arioch » Sat May 04, 2019 12:42 am

PrivateHudson wrote:I've got an impression that anti-missiles during defensive fire don't consume ammo. Is this intended?

Yes. Once upon a time it did, but I felt that it was both a gameplay problem and somewhat unrealistic that defensive fire should deplete offensive ammunition.


Return to “Testing”

Who is online

Users browsing this forum: No registered users and 6 guests

cron