Page 65 of 111

Re: Report - Current Bugs and Issues

Posted: Sun Mar 05, 2017 1:20 pm
by zolobolo
Two races have the same pop growth estimate for the next turn despite having different growth rate and base pop number:
https://www.dropbox.com/s/83ti0tn2mg5801m/SameGrowth.JPG?dl=0

Humans have higher growth rate (medium while Lummox have Very low)
If the Lummox are reduced to the same number via transporting them away, they both display the same growth rate and same effective growth rate so what is the growth rate description for if in the end it results to the exact same effective growth when combined with the current pop?

Re: Report - Current Bugs and Issues

Posted: Tue Mar 07, 2017 12:10 am
by sven
SirDamnALot wrote:Someone had problems with bombarding planets. Now I have this incident to :)
r19871 Game_3290
Bombed Procyon, dropped 59 bombs with "Bomb All", No Effect. (Mr. Worf would be proud... :mrgreen: )


This was tricky one; but I think I finally tracked down the cause. Looks like some unnecessary bit-hacking was causing an issue in the 64-bit build, which could result in this very rare bug. Should be patched as of r19894.

Re: Report - Current Bugs and Issues

Posted: Fri Mar 10, 2017 8:40 pm
by zolobolo
Pirates have several colony ships on this map, one of which just parks at a planet which has been invaded by Marauders?
https://www.dropbox.com/s/xlxecmh247hhsr6/Pirate%20Colony%20Ship.JPG?dl=0

What is this about, should the Prite faction supposed to expand?
If yes, the colony ships are not moving

Re: Report - Current Bugs and Issues

Posted: Fri Mar 10, 2017 9:21 pm
by Arioch
zolobolo wrote:Pirates have several colony ships on this map, one of which just parks at a planet which has been invaded by Marauders?
https://www.dropbox.com/s/xlxecmh247hhsr6/Pirate%20Colony%20Ship.JPG?dl=0

What is this about, should the Prite faction supposed to expand?
If yes, the colony ships are not moving


Pirates do occasionally have colony ships and transports, representing their nomadic nature. They don't use them to settle colonies.

Re: Report - Current Bugs and Issues

Posted: Sun Mar 12, 2017 12:07 pm
by zolobolo
Boarding is enabled in odd situations:
1. Yoral Fregat can board after taken by the player by it peers
2. Marauder Transport can be boarded with some of the Yoral designs

Is this know?
If you want I can look into this closer when it occurs

Re: Report - Current Bugs and Issues

Posted: Mon Mar 13, 2017 11:07 pm
by nweismuller
Game 3430: Armed Merchant 'Protector' at Elnath system unable to embark units or population despite having no passengers- its Battle Mechs were lost in action while invading the planet, and I attempted to consolidate the Marauders from earlier captured transports onto my armed merchants.

Re: Report - Current Bugs and Issues

Posted: Tue Mar 14, 2017 12:03 am
by Arioch
nweismuller wrote:Game 3430: Armed Merchant 'Protector' at Elnath system unable to embark units or population despite having no passengers- its Battle Mechs were lost in action while invading the planet, and I attempted to consolidate the Marauders from earlier captured transports onto my armed merchants.

It looks like it's being confused by the raider somehow. If you unload one of the battle mechs, you can then load the raider and then reload the mech. I'll mention it to Sven.

Re: Report - Current Bugs and Issues

Posted: Tue Mar 14, 2017 9:43 am
by nweismuller
Minor but irritating bug. 'First colony' message interrupts placing a queue on that colony if you entered the planet screen by clicking on the question mark on the planet in the bottom bar, rather than through the colony list side bar. Easily replicated- choose a faction with a habitable world in their home system, colonise, and enter the planet screen via the bottom bar rather than the side bar.

Re: Report - Current Bugs and Issues

Posted: Mon Apr 10, 2017 7:34 am
by nweismuller
game_3591: Artificial Organisms technology no longer upgrades Farms to level 2. Please fix ASAP; playing through a game with level 1 Farms is doubtless going to be 'exciting'.

Re: Report - Current Bugs and Issues

Posted: Mon Apr 10, 2017 8:11 am
by sven
nweismuller wrote:game_3591: Artificial Organisms technology no longer upgrades Farms to level 2. Please fix ASAP; playing through a game with level 1 Farms is doubtless going to be 'exciting'.


Should be fixed in 20253. :oops:

Re: Report - Current Bugs and Issues

Posted: Tue Apr 11, 2017 11:20 am
by Chasm
Possible bug: the ashdar destroyer hull has a pair of fixed forward medium mounts. These mounts cannot carry light class weapons (except for anti missiles). In contrast the ashdar light cruiser also has fixed medium mounts but CAN mount light weapons in them. (To see what I mean start a fresh game and visit the design screen.)
Correction, medium mounts aren't supposed to be able to mount light weapons, but CAN mount anti missiles (which are a light weapon)

Re: Report - Current Bugs and Issues

Posted: Fri Apr 21, 2017 7:45 pm
by siyoa
playing Phidi in tech tree view of research I get a crash when selecting 'Primary Artillery' ... I guess reason is Phidi not having access to 'Dreadnoughts' and this part of code is not happy ?

Code: Select all

prereq=all_of( one_of('Stupendous Energy Physics', 'Dreadnoughts'),'Primary Beams'),


EDIT:

'Stupendous Energy Physics' is Orthin tech only, so if anyone is having an issue with this one playing race which has no 'Dreadnoughts', my quick fix for this, find "tech 'Primary Artillery'" in ~TECHNOLOGY.lua and change its "prereq=" section to

Code: Select all

prereq=all_of( one_of('Stupendous Energy Physics', 'Super-Dreadnoughts', 'Dreadnoughts'),'Primary Beams'),

Re: Report - Current Bugs and Issues

Posted: Wed Apr 26, 2017 12:22 pm
by nweismuller
'Stars in Shadow has just hit a particularly nasty bug'- after attempting to launch after the most recent update with .dll changes. I got a 'crash.dmp' file; how should I go about getting this to you? The forum says it has an invalid extension for attaching to a post.

Re: Report - Current Bugs and Issues

Posted: Wed Apr 26, 2017 2:16 pm
by bjg
nweismuller wrote:'Stars in Shadow has just hit a particularly nasty bug'- after attempting to launch after the most recent update with .dll changes. I got a 'crash.dmp' file; how should I go about getting this to you? The forum says it has an invalid extension for attaching to a post.

crash.dmp probably has a size of your memory (8 gig? 16?), and is not very useful anyway. Means that something went terribly wrong, and the SiS isn't necessary the real cause. Try to reboot the computer and see if the crash happens again.

Re: Report - Current Bugs and Issues

Posted: Wed Apr 26, 2017 8:15 pm
by nweismuller
bjg wrote:
nweismuller wrote:'Stars in Shadow has just hit a particularly nasty bug'- after attempting to launch after the most recent update with .dll changes. I got a 'crash.dmp' file; how should I go about getting this to you? The forum says it has an invalid extension for attaching to a post.

crash.dmp probably has a size of your memory (8 gig? 16?), and is not very useful anyway. Means that something went terribly wrong, and the SiS isn't necessary the real cause. Try to reboot the computer and see if the crash happens again.


Doesn't help, and the crash only started with the latest update. At this point I am unable to launch the game.