Report - Current Bugs and Issues

A forum for chatting about in-development game features.

Moderator: luciderous

User avatar
harpy eagle
Posts: 276
Joined: Sat Mar 10, 2018 3:25 am

Re: Report - Current Bugs and Issues

Postby harpy eagle » Tue Apr 24, 2018 6:24 am

Also, cloaked ships remain cloaked after their distortion generators are knocked out. It would make sense if they uncloaked if their cloaking device is damaged.

zolobolo
Posts: 918
Joined: Fri Nov 25, 2016 3:49 pm

Re: Report - Current Bugs and Issues

Postby zolobolo » Tue Apr 24, 2018 7:49 pm

Harpies and pirates never invade for some time now on default setting

User avatar
harpy eagle
Posts: 276
Joined: Sat Mar 10, 2018 3:25 am

Re: Report - Current Bugs and Issues

Postby harpy eagle » Wed Apr 25, 2018 4:59 pm

setup_commands error - can't continue the game. Opening up the affected battle results in black screen. #6625

Image

User avatar
harpy eagle
Posts: 276
Joined: Sat Mar 10, 2018 3:25 am

Re: Report - Current Bugs and Issues

Postby harpy eagle » Fri Apr 27, 2018 11:10 pm

Assertion failed: game #6640

Using modded code, but I don't think that is cause. For some reason a design inside empire.design belongs to a different empire. I printed out the design_name and it was a Space Station.

zolobolo
Posts: 918
Joined: Fri Nov 25, 2016 3:49 pm

Re: Report - Current Bugs and Issues

Postby zolobolo » Sat Apr 28, 2018 10:29 am

There is a small inconsistency when it comes to displaying torpedoes on Yoral Advanced Destroyers

As seen below, the visuals show two torpedo mounted but only one will be utilized during battle as displayed in the right hand side

Obviously this is a minor thing, and it also happens the other way around as even in the below example it is visible that only one missile is displayed whereas two will be fired each round, but this is the only case (+Light Cruiser for the same reason) I have seen so far where the visuals over-represent the actual amount
Attachments
One or Two.png
One or Two.png (658.41 KiB) Viewed 1458 times

User avatar
sven
Site Admin
Posts: 1390
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Sun Apr 29, 2018 10:14 pm

harpy eagle wrote:The AI was transferring 1 pop of Enfi from Sabik to Suhail III. While enroute the colony was destroyed by the Orthin. After arriving, the transport was redirected to itoran, a system with an outpost but no colonies. Once it arrived at itoran, it looks like the AI sent it back to suhail (green dashed line instead of blue), and once it got there this happened.


This one should be fixed as of r22256.

User avatar
Captainspire
Posts: 144
Joined: Mon Mar 30, 2015 8:30 pm

Re: Report - Current Bugs and Issues

Postby Captainspire » Tue May 01, 2018 5:00 pm

Possible Problem : Buying Tech from Herald does not give research

There are some technologies like the
ARDA Puzzle Box and Persuasion Matrix and some others seem to allow them to be researched, but not given.
With some of these techs being offered so early in the game is difficult to research early and become hard to integrate late in the game.

Core Tap Mining is one such tech where we originally would buy the tech from the Herald, and now it seems we buy the -ability- to research the tech.

Rail Guns - I remember when having these meant you won the game, Currently, way up the food chain or research, they seem ineffective against ships, even when you boat them on a massive ship and only seem to be any good against an un-shielded planet. Were we going to leave them be for now or make them a bit more powerful for late gave use?

User avatar
Arioch
Posts: 1074
Joined: Sun Feb 01, 2015 12:56 am
Location: San Jose, California
Contact:

Re: Report - Current Bugs and Issues

Postby Arioch » Thu May 03, 2018 11:22 pm

Techs and Codexes (which are tech unlocks rather than the tech itself) are distinctly labeled in the Herald trading menu.

Core Tap Mining is a recent addition and it has always been a Codex (an unlock, not the tech itself); as far as I'm aware, you never had the ability to buy the tech outright.

zolobolo
Posts: 918
Joined: Fri Nov 25, 2016 3:49 pm

Re: Report - Current Bugs and Issues

Postby zolobolo » Sat May 05, 2018 6:11 pm

Orthin reverse engineering of a Colonial Escort Carrier returned the tech of the carrier - it is my understanding that this should not happen

The unlocked tech did not seem to have any effect on the faction: no Escort Carrier available for production
Attachments
Reverse engineering.GIF
Reverse engineering.GIF (261.39 KiB) Viewed 1363 times

User avatar
Supermint
Posts: 14
Joined: Mon Sep 25, 2017 2:54 pm
Location: Sheffield, England

Re: Report - Current Bugs and Issues

Postby Supermint » Sun May 06, 2018 8:20 pm

There is a new small but noticeable graphical glitch that has appeared. Just thought I'd let you know.
Attachments
Graphic flitch.png
Graphic flitch.png (841.06 KiB) Viewed 1353 times

zolobolo
Posts: 918
Joined: Fri Nov 25, 2016 3:49 pm

Re: Report - Current Bugs and Issues

Postby zolobolo » Mon May 07, 2018 3:26 pm

Bug when enemy civilian transports arrive the same turn when enemy planet is occupied: they cannot land and when engaged the GUI is strange, does not have an autocombat option and returns below error when battle is initiated
Attachments
Civilans arriving.GIF
Civilans arriving.GIF (182.22 KiB) Viewed 1338 times
Civilians Arriving 2.GIF
Civilians Arriving 2.GIF (98.09 KiB) Viewed 1338 times

User avatar
sven
Site Admin
Posts: 1390
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Mon May 07, 2018 4:01 pm

zolobolo wrote:Bug when enemy civilian transports arrive the same turn when enemy planet is occupied: they cannot land and when engaged the GUI is strange, does not have an autocombat option and returns below error when battle is initiated


Interesting! It looks like you've managed to hook into an ancient code path for handling intercepted civilians. Could you upload a copy of this save?

User avatar
sven
Site Admin
Posts: 1390
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Mon May 07, 2018 7:27 pm

Supermint wrote:There is a new small but noticeable graphical glitch that has appeared. Just thought I'd let you know.


Thanks for noticing this -- but I'm afraid the truth is these glitches have been occurring since the colored border feature was first implemented. There's a bunch of cases that the line rendering code doesn't quite handle properly; but my current thinking is that as long as those sorts of errors are rare and minor, it's not too big a deal.

zolobolo
Posts: 918
Joined: Fri Nov 25, 2016 3:49 pm

Re: Report - Current Bugs and Issues

Postby zolobolo » Thu May 10, 2018 7:37 am

sven wrote:
zolobolo wrote:Bug when enemy civilian transports arrive the same turn when enemy planet is occupied: they cannot land and when engaged the GUI is strange, does not have an autocombat option and returns below error when battle is initiated


Interesting! It looks like you've managed to hook into an ancient code path for handling intercepted civilians. Could you upload a copy of this save?

Please find save attached

To reproduce, click on the attack action against the civilian ships
Attachments
Orthin Fourth.rar
(912.5 KiB) Downloaded 32 times

User avatar
sven
Site Admin
Posts: 1390
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Fri May 11, 2018 10:20 pm

zolobolo wrote:To reproduce, click on the attack action against the civilian ships


Thanks for the upload. This one should be fixed as of r37526.


Return to “Testing”

Who is online

Users browsing this forum: zolobolo and 8 guests