Report - Current Bugs and Issues

A forum for chatting about in-development game features.

Moderator: luciderous

nweismuller
Posts: 176
Joined: Wed Apr 29, 2015 2:33 am

Re: Report - Current Bugs and Issues

Postby nweismuller » Thu Sep 07, 2017 7:50 pm

Another unignorable blackscreen error that should probably be prioritised to fix, triggered when I tried to contact the mercenary exchange. The mercenary exchange is as such currently unusable:

Code: Select all

Lua state\GUI\~GalaxyMap\@TradingOverlay.lua:1494: attempt to index field 'trading_name' (a nil value)
Lua state\GUI\~GalaxyMap\@TradingOverlay.lua:1494:
 ...tate\GUI\~GalaxyMap\@ThroneRoomScene\ThroneRoomScene.lua:305:
  Lua state\@@util\restore_color.lua:16:
   Lua state\@@util\restore_color.lua:9:
    Lua state\Drawers\draw_from_fullscreen_buffer.lua:66


Edit: Appears to be fixed in latest update. Thanks for taking care of that so quickly.

zolobolo
Posts: 361
Joined: Fri Nov 25, 2016 3:49 pm

Re: Report - Current Bugs and Issues

Postby zolobolo » Sat Sep 09, 2017 8:13 pm

Error message, and CTD when allowing or denying colonisation via diplomacy menu, resolved with latest patch to version: r21061

Thanks

User avatar
Captainspire
Posts: 117
Joined: Mon Mar 30, 2015 8:30 pm

Re: Report - Current Bugs and Issues

Postby Captainspire » Sun Sep 10, 2017 4:42 am

Game_4438 uploaded

The Atmosphere Generation research that allows for limited transformations only seems to work on glacier planets, however not all glacier planets.

For example, it works on Kazatel IV but is not an option on Eluz.

Ashbery76
Posts: 74
Joined: Tue Feb 03, 2015 9:04 pm

Re: Report - Current Bugs and Issues

Postby Ashbery76 » Mon Sep 18, 2017 4:33 pm

I am getting 4 new maps but not 7 in the update.

User avatar
Arioch
Posts: 876
Joined: Sun Feb 01, 2015 12:56 am
Location: San Jose, California
Contact:

Re: Report - Current Bugs and Issues

Postby Arioch » Mon Sep 18, 2017 4:41 pm

Ashbery76 wrote:I am getting 4 new maps but not 7 in the update.

"Several" new map shapes. Not seven.

wminsing
Posts: 92
Joined: Tue Feb 03, 2015 1:51 am

Re: Report - Current Bugs and Issues

Postby wminsing » Fri Sep 22, 2017 12:30 am

Report with the new Legacies DLC installed:

Playing as the Tinkers, I can not invade neutral colonies. Get an error every time I try to examine the colony, look at the defenses or click on the attack button.

Have not replicated the effect with another species yet.

-Will

User avatar
sven
Site Admin
Posts: 1171
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Fri Sep 22, 2017 1:01 am

wminsing wrote:Report with the new Legacies DLC installed:

Playing as the Tinkers, I can not invade neutral colonies. Get an error every time I try to examine the colony, look at the defenses or click on the attack button.


Should be fixed in 21234. Thanks for the report. (The main reason I'm still keeping this build on 'dev' is that the harmonize mechanic remains a WIP. But bug reports on most other features are very much appreciated.)

rustyi
Posts: 6
Joined: Sat Feb 11, 2017 3:36 am
Location: San Francisco, CA

Re: Report - Current Bugs and Issues

Postby rustyi » Fri Sep 22, 2017 1:57 am

Dev bug. r21227
Playing as tinkerers. A few times now I've started auto-combat against orthin (different planets). Each time getting a game-breaking bug (below) giving me restart option (not CTD).
error reports: game_4496; game_4496; game_4498
EDIT: save game zip also attached.

Code: Select all

Lua state\@Technology\@Improvements\ImprovementIcons.lua:173: 'for' limit must be a number
Lua state\@Technology\@Improvements\ImprovementIcons.lua:173:draw_icons:
 Lua state\@Technology\@Improvements\ImprovementIcons.lua:379:
  Lua state\@@util\restore_color.lua:9:draw_improvement_icons:
   Lua state\GUI\~GalaxyMap\@GroundCombatPane.lua:542:draw_structures:
    Lua state\GUI\~GalaxyMap\@GroundCombatPane.lua:656



EDIT: More fun!
Updated to 21234. Re-loaded game. Error on load. I suspect I need to start a new game (save not compatible between 21227 and 21234 builds), but figured I'd report if helpful. If not, feel free to ignore.

Code: Select all

Lua state\@Technology\SystemMethods.lua:5: attempt to index field 'info' (a nil value)
Lua state\@Technology\SystemMethods.lua:5:
 Lua state\Galaxy\cloaking_mechanics.lua:60:
  Lua state\Galaxy\cloaking_mechanics.lua:20:
   Lua state\Drawers\better_ship_icons.lua:653:HatDM:
    Lua state\GUI\~GalaxyMap\@FleetIcons.lua:929:do_ship_icon:HatDM
Attachments
Tinkers Save.7z
(1.1 MiB) Not downloaded yet

User avatar
sven
Site Admin
Posts: 1171
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Fri Sep 22, 2017 3:23 am

rustyi wrote:Updated to 21234. Re-loaded game. Error on load. I suspect I need to start a new game (save not compatible between 21227 and 21234 builds)


Yes, you do indeed need to restart. It' just you and Wil playing at the moment, so I'm being very careless about making potentially game breaking changes. Let me know if you hit any more errors after starting a 21234 game though.

wminsing
Posts: 92
Joined: Tue Feb 03, 2015 1:51 am

Re: Report - Current Bugs and Issues

Postby wminsing » Fri Sep 22, 2017 12:51 pm

Yes, you do indeed need to restart. It' just you and Wil playing at the moment, so I'm being very careless about making potentially game breaking changes. Let me know if you hit any more errors after starting a 21234 game though.


That's a-ok, I will keep plowing through and let you know what else I find.

-Will

wminsing
Posts: 92
Joined: Tue Feb 03, 2015 1:51 am

Re: Report - Current Bugs and Issues

Postby wminsing » Fri Sep 22, 2017 12:52 pm

Should be fixed in 21234. Thanks for the report. (The main reason I'm still keeping this build on 'dev' is that the harmonize mechanic remains a WIP. But bug reports on most other features are very much appreciated.)


I'll test the fix tonight!

-Will

wminsing
Posts: 92
Joined: Tue Feb 03, 2015 1:51 am

Re: Report - Current Bugs and Issues

Postby wminsing » Fri Sep 22, 2017 10:41 pm

Found two bugs on build r21241. First is reported in game 2403. I can now examine a neutral planet's details, but when I try to contact the leader of the world I get a 'Nil Planet' error.

The other problem isn't throwing an error message but I can't build colony ships; reports that population is insufficient, even though I have 8 pops. Restarted the game and same issue. This one is making further testing a little hard. :P

-Will

wminsing
Posts: 92
Joined: Tue Feb 03, 2015 1:51 am

Re: Report - Current Bugs and Issues

Postby wminsing » Fri Sep 22, 2017 11:03 pm

Just tried to fire up a new game as the Teros to test out some other stuff, got this error:

Code: Select all

Lua state\Setup\init_all_stars.lua:18: attempt to perform arithmetic on field '?' (a nil value)
Lua state\Setup\init_all_stars.lua:18:init_homeworld_improvements:
 Lua state\Setup\init_all_stars.lua:181:player_start:
  Lua state\Setup\init_all_stars.lua:496:init_home_system:
   Lua state\Setup\init_all_stars.lua:509:init_all_stars:
    Lua state\Setup\new_galaxy.lua:482
Lua state\Sounds\looping_sounds.lua:10: attempt to index local '(in)' (a nil value)
Lua state\Sounds\looping_sounds.lua:10:do_rollover_sound:
 Lua state\Sounds\looping_sounds.lua:47:
  Lua state\GUI\@EventDispatcher.lua:351:RaceSelection.lua:708:
   Lua state\GUI\StartScreen\~StartScreen.lua:216StartScreen.StartScreen :
 :
Lua state\GUI\~GalaxyMap\@DrawStarCenters.lua:357: attempt to call field '?' (a nil value)
Lua state\GUI\~GalaxyMap\@DrawStarCenters.lua:357:
 Lua state\GUI\~GalaxyMap\@DrawStarCenters.lua:480:get_star_picking_rect:
  Lua state\GUI\~GalaxyMap\@DrawStarNames.lua:109:draw_name:
   Lua state\GUI\~GalaxyMap\@DrawStarNames.lua:180:
    Lua state\@@util\restore_color.lua:9:f

DDPD
Posts: 29
Joined: Sun Feb 05, 2017 3:47 pm

Re: Report - Current Bugs and Issues

Postby DDPD » Sat Sep 23, 2017 2:09 am

Fired up SiS and had the Tinkers stuff. Really, really digging the content, but I've been inundated with bugs and issues. Couldn't really get too far.

Sent a bunch of bug reports!

User avatar
Captainspire
Posts: 117
Joined: Mon Mar 30, 2015 8:30 pm

Re: Report - Current Bugs and Issues

Postby Captainspire » Sat Sep 23, 2017 2:42 am

Uploaded "game_4514"

Issue: Unable to build a colony ship.
The warning says that Sindri I lacks the population to equip a colony ship

(Stable) 7,800,000 Enfi
(+80k) 1,293,548 1,293,548

I was able to build colony planets in system, but not ships


Return to “Testing”

Who is online

Users browsing this forum: No registered users and 2 guests