Report - Current Bugs and Issues

A forum for chatting about in-development game features.

Moderator: luciderous

User avatar
sven
Site Admin
Posts: 1499
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Thu Feb 25, 2016 2:16 pm

bjg wrote:Marauders are partially broken in the 32 version too. Seems like a regression. :(
Have uploaded few errors.
Also uploaded game_857. Just hit the "next turn" to reproduce.


This is actually an entirely different error. The Marauder ships at Azimir are leftovers from a base that was conquered 30 turns ago -- but, something about the way it happened left them in an odd state. Thanks for the uploads.

bjg
Posts: 616
Joined: Wed Feb 03, 2016 10:55 pm

Re: Report - Current Bugs and Issues

Postby bjg » Thu Feb 25, 2016 2:54 pm

Interesting. It was an AI that did it, perhaps due to another bug.
I'm glad I've found a new error (or two). Is there a way I can continue that game or it's screwed?

User avatar
sven
Site Admin
Posts: 1499
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Thu Feb 25, 2016 3:44 pm

bjg wrote:Interesting. It was an AI that did it, perhaps due to another bug.
I'm glad I've found a new error (or two). Is there a way I can continue that game or it's screwed?


Just posted a patch to stable that should work around the issue (r14765). Interactions with those Marauders may still trigger bugs -- they really shouldn't exist in their present state :oops:

bjg
Posts: 616
Joined: Wed Feb 03, 2016 10:55 pm

Re: Report - Current Bugs and Issues

Postby bjg » Thu Feb 25, 2016 3:57 pm

sven wrote:Just posted a patch to stable that should work around the issue (r14765). Interactions with those Marauders may still trigger bugs -- they really shouldn't exist in their present state :oops:

Thanks! Is there something you'd not like me to do or is it just a disclaimer?

User avatar
sven
Site Admin
Posts: 1499
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Thu Feb 25, 2016 3:59 pm

bjg wrote:
sven wrote:Just posted a patch to stable that should work around the issue (r14765). Interactions with those Marauders may still trigger bugs -- they really shouldn't exist in their present state :oops:

Thanks! Is there something you'd not like me to do or is it just a disclaimer?


Just a disclaimer -- I haven't really "fixed" the problem yet -- just replaced the error with a warning.

User avatar
sven
Site Admin
Posts: 1499
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Fri Feb 26, 2016 1:14 am

mute wrote:SIS will hang from time to time in combat, I haven't been able to 100% reproduce the hang but it is associated with the following elements though not necessarily in this order:
  1. Fleet size greater than ~5 combatants
  2. Selecting all ships
  3. Issuing a simultaneous move order
  4. Toggling weapon settings
  5. Ending the turn

It doesn't stop my machine, but the SIS becomes completely unresponsive. When I check on taskmanager I don't see a memory leak, but I'll check it through Process Explorer going forward and see if that sheds any light on things.


Thanks for this report, and the associated log uploads. My best hunch, at this point, is that bug may be somehow specific to SLI mode. We have other GeForce GTX 400 series in the beta (I actually have one in my development box), and this is the first time I've seen these sorts of OpenGL exceptions.

Could you try disabling SLI while running SiS, then seeing if multi-ship moves are still prone to crashes?

Doomed
Posts: 6
Joined: Sun Nov 29, 2015 6:23 pm

Re: Report - Current Bugs and Issues

Postby Doomed » Fri Feb 26, 2016 3:38 pm

I've got an issue where a Marauder is blockading one of my systems (Cheleb)

I move a fleet to Cheleb but it cannot attack the Marauder fleet and the planet still shows as blockaded.

I've submitted file - "game_864" which is under version r14773 althiough the game was started in the Jan 25th build.

If I remember correctly the marauder ship retreated from a battle in another system

mharmless
Posts: 235
Joined: Sun Feb 01, 2015 11:11 pm
Location: Washington State

Re: Report - Current Bugs and Issues

Postby mharmless » Fri Feb 26, 2016 10:25 pm

Doomed wrote:If I remember correctly the marauder ship retreated from a battle in another system


I got this to reproduce before too, with the key seeming to be that the retreating fleet was the last of its faction of marauders.

User avatar
sven
Site Admin
Posts: 1499
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Fri Feb 26, 2016 11:18 pm

mharmless wrote:
Doomed wrote:If I remember correctly the marauder ship retreated from a battle in another system


I got this to reproduce before too, with the key seeming to be that the retreating fleet was the last of its faction of marauders.


Yeah, thanks to both of you for reporting this one. There is indeed some strangeness going on with these sorts of "orphaned" marauder fleets. It's not a high priority bug (as it happens rarely, and it's often harmless), but, I can replicate the behavior, and should get around to fixing it eventually (probably as part of the big diplomacy system update).

bjg
Posts: 616
Joined: Wed Feb 03, 2016 10:55 pm

Re: Report - Current Bugs and Issues

Postby bjg » Thu Mar 03, 2016 4:32 pm

Metal still overlay research in the status bar if numbers are big.
SiS_satusbar.PNG
SiS_satusbar.PNG (4.23 KiB) Viewed 6157 times

bjg
Posts: 616
Joined: Wed Feb 03, 2016 10:55 pm

Re: Report - Current Bugs and Issues

Postby bjg » Thu Mar 03, 2016 4:42 pm

Can't click on ships in the lower third of the strategic screen, even than there is no "event" panel there.

User avatar
sven
Site Admin
Posts: 1499
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Thu Mar 03, 2016 4:47 pm

bjg wrote:Can't click on ships in the lower third of the strategic screen, even than there is no "event" panel there.


I can't replicate this one. Would you upload a map where it's happening?

bjg
Posts: 616
Joined: Wed Feb 03, 2016 10:55 pm

Re: Report - Current Bugs and Issues

Postby bjg » Thu Mar 03, 2016 5:44 pm

It happens on every map, but now I can't reproduce it myself (loading fresh from the save). There are probably some steps I do that confuse UI into thinking the panel is there than it's not. Sorry for an unreliable report.

User avatar
sven
Site Admin
Posts: 1499
Joined: Sat Jan 31, 2015 10:24 pm
Location: British Columbia, Canada
Contact:

Re: Report - Current Bugs and Issues

Postby sven » Thu Mar 03, 2016 5:45 pm

bjg wrote:It happens on every map, but now I can't reproduce it myself (loading fresh from the save). There are probably some steps I do that confuse UI into thinking the panel is there than it's not. Sorry for an unreliable report.


Hrm. Well, just knowing that it can happen at all is useful. If you can figure out how to replicate it, let me know.

bjg
Posts: 616
Joined: Wed Feb 03, 2016 10:55 pm

Re: Report - Current Bugs and Issues

Postby bjg » Thu Mar 03, 2016 6:26 pm

Think I know how to reproduce it. Click on any Transport, click "start trading" (the panel dissapears) - the ships in the lower third become "unclickable".


Return to “Testing”

Who is online

Users browsing this forum: No registered users and 5 guests

cron